API response slower than normal
Incident Report for Shippable
Resolved
This incident has been resolved.
Posted 7 months ago. Mar 28, 2017 - 18:50 PDT
Update
We have figured out that sockets are not draining fast enough and causing garbage collection delays. This is resulting in APIs getting overloaded intermittently. We are going to deploy a fix on 4/4 deployment but until then we have enough capacity and we are monitoring it. We will resolve this after deployment.
Posted 7 months ago. Mar 28, 2017 - 16:40 PDT
Monitoring
We noticed significant increase in load around 8am PST which doubled our response time. We have added extra API capacity to mitigate the issue in short term. We are investigating the underlying cause...

Currently response time is back to 300+ ms down from 650+ ms
Posted 7 months ago. Mar 28, 2017 - 11:19 PDT