Login with BitBucket is failing
Incident Report for Shippable
Resolved
BitBucket login is working correctly and no new 401 errors have been reported. The service is functioning normally now.
Posted 3 months ago. Sep 20, 2018 - 01:43 PDT
Monitoring
A fix is in place and BitBucket login is now working as expected. We are continuing to monitor the service for any anomalies.
Posted 3 months ago. Sep 20, 2018 - 01:08 PDT
Identified
All calls to the BitBucket API were being rejected with 401 responses. We have narrowed this down to our IP address being blocked at BitBucket's end. We are working around this by shifting to a new IP address.
Posted 3 months ago. Sep 20, 2018 - 01:07 PDT
Investigating
Logging in to Shippable using BitBucket fails with an OAuth error. We are investigating.
Posted 3 months ago. Sep 20, 2018 - 00:18 PDT
This incident affected: Source Control Providers (Atlassian Bitbucket (API)).