Shippable service is down
Incident Report for Shippable
Resolved
The issue is resolved and the service is back up now. .
Posted 11 months ago. Jan 19, 2017 - 23:23 PST
Identified
The Shippable service is currently unavailable. We're working on bringing it back up as soon as possible. We'll post an update soon.
Posted 11 months ago. Jan 19, 2017 - 22:47 PST