Pull requests on private repositories from BitBucket are failing
Incident Report for Shippable
Resolved
We have changed the strategy used to build pull requests on private repositories from Bitbucket. Builds should not fail in the git_sync step anymore.
Posted about 1 year ago. Oct 06, 2017 - 06:26 PDT
Identified
We have identified an issue with building pull requests on private repositories from BitBucket. Builds are failing in the git_sync step because the format of the SSH URL for the repository (as synchronized from the BitBucket API) has changed at some point in the last 24 hours, causing our git_sync to treat some pull requests incorrectly.

We are actively working towards a fix.
Posted about 1 year ago. Oct 06, 2017 - 03:51 PDT